HTTP-Sms_KYSms.asp

http://sms.mobset.com/SDK2/Sms_GetCM.asp
功能 |  | 取短信签名(短信实名)
使用前提 |  | 取得发送帐号
参数 | CorpID | 企业ID
 | LoginName Passwd TimeStamp | 登录用户名 帐号密码，可选参数。如果不附加此参数，将使用IP地址验证帐号合法性。加密方式：MD5(CorpID+密码+TimeStamp) 时间戳， MMDDHHMMSS（月日时分秒),如 0514094912
返回 | 1 | 返回短信签名(短信实名)，如果为空，则表明此帐号没有签名
 | -1 | 输入参数不完整
 | -2 | 非法来源IP地址或帐号密码有误
 | -3 -10 | 连接数据库失败帐号有误 时间戳错误，需要使用当前时间的时间戳，格式是：MMDDHHMMSS（月日时分秒),如 0514094912
调用示例 |  | Sms_GetCM.asp?CorpID=100000&LoginName=Admin&TimeStamp=0514094912


HTTP-Sms_KYSms.asp

http://sms.mobset.com/SDK2/Sms_KYSms.asp
功能 |  | 取本帐号剩余可用的短信量。参数传输方式可以Get，也可为POST
使用前提 |  | 取得发送帐号
参数 | CorpID | 企业ID
 | LoginName Passwd TimeStamp XML | 登录用户名 帐号密码，可选参数。如果不附加此参数，将使用IP地址验证帐号合法性。加密方式：MD5(CorpID+密码+TimeStamp) 时间戳， MMDDHHMMSS（月日时分秒),如 0514094912 是否以XML文件返回，为1时通过XML返回数据
返回 | >=0 | 返回剩余可用的短信量
 | -1 | 输入参数不完整
 | -2 | 非法来源IP地址或帐号密码有误
 | -3 -10 | 连接数据库失败帐号有误 时间戳错误，需要使用当前时间的时间戳，格式是：MMDDHHMMSS（月日时分秒),如 0514094912
调用示例 |  | Sms_KYSms.asp?CorpID=100000&LoginName=Admin&TimeStamp=0514094912


HTTP-Sms_Recv.asp

http://sms.mobset.com/SDK2/Sms_Recv.asp
功能 |  | 取接收到的短消息，可能会一次返回多条记录。参数传输方式可以Get，也可为POST。注意:接收的短信在我们服务器仅保留2天。
使用前提 |  | 取得发送帐号
参数 | CorpID | 企业ID
 | LoginName Passwd TimeStamp | 登录用户名 帐号密码，可选参数。如果不附加此参数，将使用IP地址验证帐号合法性。加密方式：MD5(CorpID+密码+TimeStamp) 时间戳， MMDDHHMMSS（月日时分秒),如 0514094912
 | XML | 是否以XML文件返回，为1时通过XML返回数据
返回 | >0 | 返回接收到短信的数量，空行后跟着短信接收记录，每记录以两个空行分隔
 | -1 | 输入参数不完整
 | -2 | 非法来源IP地址或帐号密码有误
 | -3 -10 | 连接数据库失败帐号有误 时间戳错误，需要使用当前时间的时间戳，格式是：MMDDHHMMSS（月日时分秒),如 0514094912
调用示例 |  | Sms_Recv.asp?CorpID=100000&LoginName=Admin&TimeStamp=0514094912&XML=1


HTTP-Sms_Send.asp

http://sms.mobset.com/SDK2/Sms_Send.asp
功能 |  | 发送指定的短信，它能自动分段发送,每段信息最大长度为70个字，并且支持一次发送多个号码，参数传输方式可以Get，也可为POST
使用前提 |  | 取得发送帐号
参数 | CorpID | 企业ID
 | LoginName | 登录用户名
 | Passwd TimeStamp | 帐号密码，可选参数。如果不附加此参数，将使用IP地址验证帐号合法性。加密方式：MD5(CorpID+密码+TimeStamp) 时间戳， MMDDHHMMSS（月日时分秒),如 0514094912
 | send_no | 发送目标号码，多个号码可以使用;号分隔，号码不要超过50个，过多号码容易产生超时，从而造成不断重复发送。
 | msg | 要发送的短信内容。
 | AddNum | 可选参数：扩展号码，如果有，会在发送的特服号后添加上此号码（受不同运营商及不同地区影响，可扩展号码的长度是不定的，建议使用前进行不同长度的附加码测试）
 | Timer | 可选参数：定时发送时间。格式为"2005-05-05 12:00:00"
 | LongSms | 可选参数：是否以长短信方式发送，为1时是。长短信有以下特点： 1、分开多条发送的短信在手机屏幕上显示的是一整条。 2、每条拆分的短信最多支持67个字。 3、某些手机可能无法收到或无法显示长短信。 4、小灵通不支持长短信。
 | RetMsg | 可选参数：是否以弹出窗口方式返回信息，为1时返回，此参数在通过浏览器调用时有用。
返回 | >0 | 发送成功，返回发送的数量，并且返回SmsID,如果有多条短信，按顺序返回。可以通过Sms_Status根据SmsID取短信状态。由于网络原因，返回的时间可能会较长，在调用时，建议控制超时值应大于30秒。
 | -1 | 输入参数不完整
 | -2 | 非法来源IP地址或帐号密码有误
 | -3 | 目标号码有误
 | -4 | 企业帐号余额不足，后跟已发送的数量及SmsID
 | -5 | 用户帐号余额不足，后跟已发送的数量及SmsID
 | -6 | 输入参数不完整
 | -7 | 连接数据库失败
 | -8 | 企业帐号已被禁用
 | -9 -10 | 短信内容含有过滤关键字 时间戳错误，需要使用当前时间的时间戳，格式是：MMDDHHMMSS（月日时分秒),如 0514094912
调用示例 |  | Sms_Send.asp?CorpID=100000&LoginName=Admin&TimeStamp=0514094912 &send_no=139123456&msg=这是测试短信
注意 |  | 短信平台带反骚扰监控系统，不允许短时间内向同一手机号码发送过多短信。 默认设置为20分钟内不允许向同一号码发送超过2条相同内容的短信；不同内容的限制为5条。


HTTP-Sms_Status.asp

http://sms.mobset.com/SDK2/Sms_Status.asp
功能 |  | 取短信状态
使用前提 |  | 取得通过Sms_Send返回的SmsID
参数 | SmsID | 短信ID
返回 | >0 | 返回短信状态，具体含义请看常量定义
 | -1 | 输入参数不完整
 | -3 | 连接数据库失败SmsID有误
调用示例 |  | Sms_Status.asp?SmsID=1007709900


HTTP-短信上行及状态报告推送

功能 |  | 当平台接收到短信或状态时，会自动调用预先设置的URL进行推送。推送的参数采用GET方式，直接在URL后附加，请参照调用示例。用户的URL无需要返回任何信息，用户端需要保证URL的稳定性，如果推送失败，将不会重试。
使用前提 |  | 取得发送帐号，并且已设定推送URL地址。（默认仅推送上行，需要推送状态报告需另外申请）
 | Type | 推送类型，MO-上行，RPT,状态报告
参数 | CorpID | 上行或状态报告对应的企业ID
 | SendNum | 上行短信的手机号码，当Type=MO时存在
 | RecvNum | 目标短信端口号，当Type=MO时存在
 | AddNum | 扩展号，与下行时的扩展号对应，当Type=MO时存在
 | Msg | 短信内容，当Type=MO时存在
 | SmsID | 短信ID，用于匹配Sms_Send返回的记录，当Type=RPT时存在
 | Status | 状态码，参考常量定义，当Type=RPT时存在
 | ExStatus | 扩展状态码，不同运营商意义不同，当Type=RPT时存在
调用示例 |  | http://xxx.xxx.xxx/Sms_Post.asp?&Type=MO&CorpID=100000&SendNum=13912345678&RecvNum=62015016001002&AddNum=002Msg=testmsg http://xxx.xxx.xxx/Sms_Post.asp?&Type=RPT&CorpID=100000&SmsID=1595975710&Status=12&EXStatus=DELIVRD


函数详解-Sms_Connect

long WINAPI Sms_Connect(const char * pServer , long lCorpID,const char * pLoginName, const char * pPasswd , long lTimeOut, HWND hWnd );
功能 |  | 初始化接口并与短信平台连接
入参 | pServer | 服务器地址，默认为:www.mobset.com
 | lCorpID | 企业ID,申请帐号时会给出
 | pLoginName | 登录帐号
 | pPasswd | 密码
 | lTimeOut | 连接或发送短消息时的等待超时时间。单位：秒，建议值30，此超时值其它函数共同使用。
 | hWnd | 用于返回信息的窗口句柄,如果不用可置NULL或0 , 当接口收到短信时会自动向窗口发送一条SMS_RECV的信息，此时应用程序调用Sms_Get来接收
返回 | 0 | 初始化成功
 | -1 | 连接服务器失败
 | -2 | 连接服务器超时
 | -3 | 登录失败，帐号有误
 | -4 | 登录失败，相同帐号已在别处登录
 | -5 | 登录失败，帐号过于频繁登录，请稍后再试
注意 |  | 初始化成功后，可以不断进行其它操作，如发送短消息，接收短消息等。程序启动后，只需要初始化一次即可，没有必要每发送一条短信进行一次连接。接口自带心跳检测功能，当断线后会自动重连，无需上层应用程序关心。 请不要过于频繁地登录与退出，否则会被自动禁用。


函数详解-Sms_DisConnect

long WINAPI Sms_DisConnect(void);
功能 |  | 释放资源,断开与服务器的连接
入参 | void |
返回 | void |


函数详解-Sms_Get

long WINAPI Sms_Get(char * pNo , char * pMsg , char * pTime);
功能 |  | 返回接收队列中状态报告。(此接收队列为中心端主动向客户端推送，取状态报告时只是从队列中获取，不占用资源。请及时收取，断电、关机、接口断开后数据丢失）
入参 | pNo | 返回短消息的发送号码
 | pMsg | 返回短消息的内容
 | pTime | 返回短消息的发送时间
返回 | >=0 | 取短信成功，短信内容在pMsg中,返回队列中还剩下的短信数量
 | -1 | 短信队列为空，取短信失败


函数详解-Sms_Get2

long WINAPI Sms_Get2(char * pSendNum , char * pRecvNum , char * pMsg , char * pTime);
功能 |  | 返回接收队列中状态报告。(此接收队列为中心端主动向客户端推送，取状态报告时只是从队列中获取，不占用资源。请及时收取，断电、关机、接口断开后数据丢失）
入参 | pSendNum | 返回短消息的发送者号码
 | pRecvNum | 返回短消息的接收号码，即是发送的目标号码
 | pMsg | 返回短消息的内容
 | pTime | 返回短消息的发送时间
返回 | >=0 | 取短信成功，短信内容在pMsg中,返回队列中还剩下的短信数量
 | -1 | 短信队列为空，取短信失败


函数详解-Sms_KYSms

long WINAPI Sms_KYSms(void);
功能 |  | 查询企业可用短信量，返回企业可用短信量与用户企业可用短信量中最小的一个。
入参 | void |
返回 | >=0 | 此帐号可用短信量
 | -1 | 接口未初始化
 | -2 | 等数据返回超时


函数详解-Sms_Proxy

long WINAPI Sms_Proxy(long lProxyType,const char * pProxyHost,long lProxyPort,const char * pProxyUser,const char * pProxyPasswd);
功能 |  | 设置代理服务器相关信息
入参 | lProxyType | 代理服务器类型,见PROXYTYPE_的定义
 | pProxyHost | 代理服务器地址
 | lProxyPort | 代理服务器端口
 | pProxyUser | 代理服务器登录帐号(如果没有，可为空)
 | pProxyPasswd | 代理服务器登录密码(如果没有，可为空)
返回 | 0 | 固定为0


函数详解-Sms_Send

long WINAPI Sms_Send(const char * pMobile , const char * pMsg , long * lSmsID );
功能 |  | 发送指定的短信，它能自动分段发送,每段信息最大长度为70个字
入参 | pMobile | 发送目标号码
 | pMsg | 需要发送的消息(信息的总长度不能超过500个字节)
 | lSmsID | 发送返回的短信ID,可根据此ID查询到此短信的状态，当发送的内容被自动分段时，返回的为第一条短信的ID
返回 | >=0 | 发送成功，返回发送的数量，当返回值为0时可能是因为帐号到期或帐号余额不足
 | -1 | 接口未初始化
 | -2 | 发送超时
 | -3 | 发送失败，可能是帐号过期或余额不足
 | -4 | 发送失败，发送的信息内容中含有敏感关键字，禁止发送。
 | -5 | 发送失败，发送的目标号码为黑名单用户，禁止发送。
 | -6 | 发送失败，目标号码有误。
注意 |  | 短信平台带反骚扰监控系统，不允许短时间内向同一手机号码发送过多短信。 默认设置为20分钟内不允许向同一号码发送超过2条相同内容的短信；不同内容的限制为5条。


函数详解-Sms_Send2

long WINAPI Sms_Send2(const char * pSendExNum ,const char * pMobile , const char * pMsg , long * lSmsID );
功能 |  | 发送指定的短信，它能自动分段发送,每段信息最大长度为70个字
入参 | pSendExNum | 发送扩展号码，发送时会在原分配的特服号尾部添加(受不同运营商及不同地区影响，可护展号码的长度是不定的，建议使用前进行不同长度的附加码测试)
 | pMobile | 发送目标号码
 | pMsg | 需要发送的消息(信息的总长度不能超过500个字节)
 | lSmsID | 发送返回的短信ID,可根据此ID查询到此短信的状态，当发送的内容被自动分段时，返回的为第一条短信的ID
返回 | >=0 | 发送成功，返回发送的数量，当返回值为0时可能是因为帐号到期或帐号余额不足
 | -1 | 接口未初始化
 | -2 | 发送超时
 | -3 | 发送失败，可能是帐号过期或余额不足
 | -4 | 发送失败，发送的信息内容中含有敏感关键字，禁止发送。
 | -5 | 发送失败，发送的目标号码为黑名单用户，禁止发送。
 | -6 | 发送失败，目标号码有误。
注意 |  | 短信平台带反骚扰监控系统，不允许短时间内向同一手机号码发送过多短信。 默认设置为20分钟内不允许向同一号码发送超过2条相同内容的短信；不同内容的限制为5条。


函数详解-Sms_SendEx

long WINAPI Sms_SendEx(SmsSend * pSms , long lCount , BOOL bWaitRet );
功能 |  | 发送短消息(此函数不会自动拆分短信)
入参 | pSms | 目标手机号与短信内容的结构(SmsSend),结构的定义见后
 | lCount | 短信发送结构的数量,数组数量不要超过50个，否则容易产生超时。
 | bWaitRet | 是否等待数据返回，如果不等待，此函数将数据送住服务器后就返回而不管结果如何
返回 | >=0 | 发送成功，返回发送的数量，当返回值为0或小于发送数量时可能是因为帐号到期或帐号余额不足，还有就是参考其它说明。
 | -1 | 接口未初始化
 | -2 | 发送超时
 | -3 | 发送失败，可能是帐号过期或余额不足
 | -4 | 发送失败，发送的信息内容中含有敏感关键字，禁止发送。
 | -5 | 发送失败，发送的目标号码为黑名单用户，禁止发送。
 | 其它说明 | 如果发送成功数量与实际要发送的数量不符，请检查pSms数组里的lSmsID，是否是以下值： -4 发送失败，发送的信息内容中含有敏感关键字，禁止发送。 -5 发送失败，发送的目标号码为黑名单用户，禁止发送。 0 发送失败，可能是帐号至期或余额不足。
注意 |  | 短信平台带反骚扰监控系统，不允许短时间内向同一手机号码发送过多短信。 默认设置为20分钟内不允许向同一号码发送超过2条相同内容的短信；不同内容的限制为5条。
SmsSend |  | typedef struct _SmsSend { long lSmsID; //发送成功后返回的ID号 long reserve; //保留，暂未用到; char szMobile[24]; //目标手机号码 char szMsg[168]; //短信内容 }SmsSend;


函数详解-Sms_SendEx2

long WINAPI Sms_SendEx2(SmsSend2 * pSms , long lCount , BOOL bWaitRet );
功能 |  | 发送短消息(此函数不会自动拆分短信)
入参 | pSms | 目标手机号与短信内容的结构(SmsSend),结构的定义见后
 | lCount | 短信发送结构的数量，数组数量不要超过50个，否则容易产生超时。
 | bWaitRet | 是否等待数据返回，如果不等待，此函数将数据送住服务器后就返回而不管结果如何
返回 | >=0 | 发送成功，返回发送的数量，当返回值为0或小于发送数量时可能是因为帐号到期或帐号余额不足，还有就是参考其它说明。
 | -1 | 接口未初始化
 | -2 | 发送超时
 | -3 | 发送失败，可能是帐号过期或余额不足
 | -4 | 发送失败，发送的信息内容中含有敏感关键字，禁止发送。
 | -5 | 发送失败，发送的目标号码为黑名单用户，禁止发送。
 | 其它说明 | 如果发送成功数量与实际要发送的数量不符，请检查pSms数组里的lSmsID，是否是以下值： -4 发送失败，发送的信息内容中含有敏感关键字，禁止发送。 -5 发送失败，发送的目标号码为黑名单用户，禁止发送。 0 发送失败，可能是帐号至期或余额不足。 受不同运营商及不同地区影响，可扩展号码的长度是不定的，建议使用前进行不同长度的附加码测试。
注意 |  | 短信平台带反骚扰监控系统，不允许短时间内向同一手机号码发送过多短信。 默认设置为20分钟内不允许向同一号码发送超过2条相同内容的短信；不同内容的限制为5条。
SmsSend2 |  | typedef struct _SmsSend2 { long lSmsID; //发送成功后返回的ID号 long reserve; //保留，暂未用到; char szSendExNum[24]; //发送扩展号码 char szMobile[24]; //目标手机号码 char szMsg[168]; //短信内容 }SmsSend2;


函数详解-Sms_Status

long WINAPI Sms_Status(long lSmsID);
功能 |  | 取短信状态
入参 | lSmsID | Sms_Send返回的信息ID
返回 | >=0 | 返回短信的状态定义，具体见常量定义SEND_STATUS_XXXX
 | -1 | 接口未初始化
 | -2 | 等数据返回超时
 | -3 | 找不到此短信


函数详解-常量

#define SMS_RECV WM_USER + 300 | 通知窗口的消息:收到短消息，请使用Sms_Get收取
#define SEND_STATUS_SUB_OK 0 | 短信状态:提交成功
#define SEND_STATUS_SUB_FILT 1 | 短信状态:含有过滤词，需要审核，现正审核中
#define SEND_STATUS_SUB_ERROR 2 | 短信状态:提交失败
#define SEND_STATUS_SUB_USERNOSMS 3 | 短信状态:提交失败
#define SEND_STATUS_SUB_CORPNOSMS 4 | 短信状态:提交失败
#define SEND_STATUS_SUB_CORPOVRDATE 5 | 短信状态:提交失败
#define SEND_STATUS_SUB_NUMNOSUP 6 | 短信状态:号码不支持
#define SEND_STATUS_FILT_ERROR 7 | 短信状态:含有过滤词，需要审核，审核不能通过
#define SEND_STATUS_SEND_OK 10 | 短信状态:发送成功
#define SEND_STATUS_SEND_ERROR 11 | 短信状态:发送失败
#define SEND_STATUS_RECV_OK 12 | 短信状态:接收成功
#define SEND_STATUS_RECV_ERROR 13 | 短信状态:接收失败
#define SEND_STATUS_UNKNOW 15 | 短信状态:未知状态
#define PROXYTYPE_NOPROXY 0 | 不使用代理服务器
#define PROXYTYPE_SOCKS4 1 | Socket4
#define PROXYTYPE_SOCKS4A 2 | Socket4A
#define PROXYTYPE_SOCKS5 3 | Socket5
#define PROXYTYPE_HTTP11 4 | HTTP 1.1


常见问题

如何在自己的账号下增加子账号？

    如果您已经取得我公司的二次开发接口的使用权，则你将会得到一个具有分配子账号权力的账号，增加子账号方法如下：
    1．请登陆短信易软件，在"公用通信录"上右击鼠标选择"添加用户"
    2．弹出窗口左栏为基本信息栏，其中"姓名"一项必须填写；右栏为用户权限栏，"属性"选项用来区分不同类型用户所拥有的权限，点击“高级选项”也可以自己设定某类型的用户所拥有的权限
    3．"用户名"由管理者自行定义，用户名即是用户登录帐号。
    4． 系统会自动生成登陆密码和特服号，特服号是指该子账号的短信发送端口编号，短信量为该帐号所能发送的短信条数。
    5． 将登陆信息栏中的信息发给该账号的使用者，即完成子账号的建立与分配。
    6． 该子账号可直接登陆使用短信易软件，为确保信息安全，如果该帐号需要使用二次开发接口提供的短信功能，请通知我们由我公司为该帐号开通此功能，我们对由此给您造成的不便致以深深的歉意。
    7． 短信易系统带反骚扰系统，不要在短时间内向用户发送过多的短信，如果超出限制范围，短信将会是发送失败。

端口号与子端口号：

     端口号是指您的账号发送短信时的发送方号码，其会在平常显示手机号码的位置显示，该帐号所分配的子账号所对应的端口号即主账号端口号+特服号，特服号即分配子账号时系统自动分配的特服号，例如您的账号为12345678，该帐号分配的某子账号的特服号为09，则该子账号的端口号为1234567809。


注意事项

使用此短信接口前请写调用Sms_Connect，使用完毕后请调用Sms_DisConnect。
收到短信时，如果有设置消息通知窗口，则会收到SMS_RECV消息，此时请调用Sms_Get来接收短信，如果一次接收到多条短信，务必根据Sms_Get的返回值判断队列中是否还有短信，直接全部接收完毕。
如果使用Delphi,VB或其它较难处理窗口消息的语言，请建立独立的线程或使用Timer，使用Sms_Get函数不断来获取新的短信息。
当需要取短信息的状态报告时，发送时请先记录Sms_Send返回的SmsID。
本接口已包含网络检测与重连机制，用户不必关心网络连接状态。


简介

短信易二次开发接口
简 介

    为了对短消息信息应用开发商提供支持，本公司提供了一个高可靠性开发接口，支持用户的短信息定向开发。该接口可运行于任何Windows平台，支持中英文短消息发送接收。随着手机短信增值业务的发展，我们将不断地增加开发软件包的功能。

    通过该短消息开发接口，企业不仅可以将其与自身的ERP/CRM/MIS系统结合，提高信息处理的实时性，还可以非常容易地建立起自己的短消息中心，用于处理客户投诉、产品推广、广告发布等常用业务，进一步提高工作效率与节省成本。此接口可广泛用于远程控制，电讯，CALL台，电力，教育，广告等行业。

    短消息二次开发接口以动态连接库的形式提供，支持所有Windows平台下开发语言，如Visual C++, VB, C++ Builder, Delphi, Power Builder和Lotus Notes等。
接口特点
接口直接移动运营商的短信网关，通过互联网登录，建设成本低。
消息的发送与接收采用消息驱动方式，速度快，效率高。
加入状态报告功能，所以接口也适用于实时性与准确性很强的应用。
接口标准化，函数少，调用简单，使用起来十分方便。
接口兼容性好，可运行于任何Windows平台，并且无需附其它程序。
应用程序可灵活应用，支持全国范围内的短消息发送与接收。
适用手机用户
中国移动
中国联通
连接方式
互联网，帐号、密码确认登录
开发接口包含函数:(更详细内容请查看SmsSDK.h文件)
Sms_Connect　　　初始化接口并与短信服务器连接
Sms_Send 　　　　发送指定的短信，支持自动分段发送
Sms_Get 　　　　 返回接收队列中短信
Sms_Exit 　　　　释放资源,断开与服务器的连接
各函数调用流程图
短信开发接口所处位置图
开发接口SmsSDK.zip包含文件：
SmsSDK.chm 　　　　　　　　　　　　短消息开发接口应用帮助文件
\SmsSDK　　　　　(DIR)
    \SmsSDK.h 　　　　　　　　　　 短消息开发接口头文件
    \SmsSDK.Lib 　　　　　　　　　 短消息开发接口库文件
    \SmsSDK.Dll 　　　　　　　　　 短消息开发接口动态连接库(主要文件)
    \SmsSDK_Demo.exe 　　　　　　　测试短消息接口的工具
\Example 　　(DIR)　　　　　　　　 示例程序与原代码
    \VC　　　　　　　　 　　　　　 Visual C++ 例子程序
    \VB 　　　　　　　　　　　　　 Visual Basic 例子程序
    \Delphi　　　　　　　　 　　　 Delphi 例子程序
    \PB 　　　　　　　　　　　　　 PowerBuilder 例子程序
    \VC_LoadLibrary　　 　　　　　 VC动态装入例子，C++Builder的可参考
    \C# 　　　　　　　　　　　　　 C# .net 例子程序
    \ASP 　　　　　　　　　　　　　ASP 例子程序
    \Java　　　　　　　　　　　　　Java接口与例子程序
广州首易信息技术有限公司
http://www.mobset.com